View Issue Details

IDProjectCategoryView StatusLast Update
0001511PartDesignFeaturepublic2017-04-28 11:26
ReporterbejantAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.17 
Summary0001511: Reintroduce PolarPatterning / MultiTransform, etc. About X, Y, and Z Axes
DescriptionSometimes a user creates a model where a cardinal axis must be used as a reference without going through workarounds as seen in the following forum thread:
http://forum.freecadweb.org/viewtopic.php?f=3&t=6307

At the time of this ticket the wiki PolarPattern page has a screen grab where X, Y, or Z axes are selectable:
http://www.freecadweb.org/wiki/index.php?title=PartDesign_PolarPattern#Options

I'm guessing this selectability once existed and was removed when the "Select Reference" option was added.

It looks like this goes back to the oldest FreeCAD version I have installed:
OS: Windows XP
Platform: 32-bit
Version: 0.14.2370 (Git)
Branch: master
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1

TagsNo tags attached.

Activities

2014-04-17 02:42bejantNew Issue

normandc

2014-04-17 03:48

manager   ~0004565

Last edited: 2014-04-17 03:48

View 2 revisions

As explained in the link topic, this is due to issue http://freecadweb.org/tracker/view.php?id=874 .

2014-04-17 03:48normandcNote Edited: 0004565View Revisions

bejant

2014-04-22 18:21

reporter   ~0004571

Thanks Norm, but even though I let it rest before filing the ticket I didn't get the explanation in time. It looks like tmoore has got this sorted out and after jriegel has a look it will be in jriegel/dev-assembly.

Gathered from the following forum thread:
http://forum.freecadweb.org/viewtopic.php?f=20&t=6364

openfablab

2017-01-17 07:19

reporter   ~0007836

I think, this functionality can be easily implemented by other way - by allowing to select for reference axes of cylindric faces (or planar arcs and circles). Almost all parts with polar patterns have central hole, pin, rim or another central cylindrical feature.

Kunda1

2017-04-26 12:00

manager   ~0008776

@NormandC wrote
This is now fixed in 0.17-dev. In addition to sketch axes, the selection includes the Body's base X Y Z axes. This has probably been added along with the big PartDesignNext merge so it would be near impossible to ID the exact commit.

Kunda1

2017-04-26 12:02

manager   ~0008777

Resolving based on NormandC's feedback.
2017-04-26 12:02Kunda1Statusnew => resolved
2017-04-26 12:02Kunda1Resolutionopen => fixed
2017-04-26 12:02Kunda1Fixed in Version => 0.17

Kunda1

2017-04-28 11:26

manager   ~0008793

Closing
2017-04-28 11:26Kunda1Statusresolved => closed

Issue History

Date Modified Username Field Change
2014-04-17 02:42 bejant New Issue
2014-04-17 03:48 normandc Note Added: 0004565
2014-04-17 03:48 normandc Note Edited: 0004565 View Revisions
2014-04-22 18:21 bejant Note Added: 0004571
2017-01-17 07:19 openfablab Note Added: 0007836
2017-04-26 12:00 Kunda1 Note Added: 0008776
2017-04-26 12:02 Kunda1 Status new => resolved
2017-04-26 12:02 Kunda1 Resolution open => fixed
2017-04-26 12:02 Kunda1 Fixed in Version => 0.17
2017-04-26 12:02 Kunda1 Note Added: 0008777
2017-04-28 11:26 Kunda1 Status resolved => closed
2017-04-28 11:26 Kunda1 Note Added: 0008793